5.1.3 Lab – Troubleshoot EIGRP for IPv6 Answers

5.1.3 Lab – Troubleshoot EIGRP for IPv6 Answers

Lab – Troubleshoot EIGRP for IPv6 (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device

Interface

IPv6 Address/Prefix Length

Link-Local Address

R1

G0/0/0

2001:db8:12::1/64

fe80::1:1

R1

G0/0/1

2001:db8:1d1::1/64

fe80::1:2

R1

S0/1/0

2001:db8:13::1/64

fe80::1:3

R2

G0/0/0

2001:db8:12::2/64

fe80::2:1

R2

G0/0/1

2001:db8:23::2/64

fe80::2:2

R2

Loopback 0

2001:db8:acad:2000::1/64

fe80::2:3

R2

Loopback 1

2001:db8:acad:2001::1/64

fe80::2:4

R3

G0/0/0

2001:db8:23::3/64

fe80::3:1

R3

G0/0/1

2001:db8:3d2::1/64

fe80::3:2

R3

S0/1/0

2001:db8:13::3/64

fe80::3:3

R3

Loopback 0

2001:db8:acad:3000::1/64

fe80::3:4

D1

G1/0/11

2001:db8:1d1::2/64

fe80::d1:1

D1

Loopback 0

2001:db8:acad:1000::1/64

fe80::d1:2

D1

Loopback 1

2001:db8:acad:1001::1/64

fe80::d1:3

D1

Loopback 2

2001:db8:acad:1002::1/64

fe80::d1:4

D1

Loopback 3

2001:db8:acad:1003::1/64

fe80::d1:5

D2

G1/0/11

2001:db8:3d2::2/64

fe80::d2:1

D2

Loopback 0

2001:db8:acad:4000::1/64

fe80::d2:2

D2

Loopback 1

2001:db8:acad:4001::1/64

fe80::d2:3

Objectives

Troubleshoot network issues related to the configuration and operation of EIGRP for IPv6.

Background / Scenario

In this topology, R1, R2, R3, D1, and D2 are EIGRP neighbors. Switch D1 provides connectivity for a large branch of the network, R2 provides connectivity for a small branch, R3 supports a single LAN enclave, and switch D2 provides both an internet connection and an extranet connection. You will be loading configurations with intentional errors onto the network. Your tasks are to FIND the error(s), document your findings and the command(s) or method(s) used to fix them, FIX the issue(s) presented here and then test the network to ensure both of the following conditions are met:

1)the complaint received in the ticket is resolved

2)full reachability is restored

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 3650 with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Make sure that the switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3560 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 PC (Choice of operating system with terminal emulation program installed)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Instructions

Part 1:Trouble Ticket 5.1.3.1

Scenario:

You took a spring break vacation, leaving the junior network administrator with some seemingly simple tasks. The routing table was to be reduced in size while the extranet on D2 and the enclave on R3 would not be visible in the routing table at all. Routing to the internet via D2 should work. Future additions to the large branch at R1 should be accounted for in the routing table so that when those networks are added (the network addresses are 2001:db8:acad:1004::/64, 2001:db8:acad:1005::/64, 2001:db8:acad:1006::/64, and 2001:db8:acad:1007::/64), there is no change to the routing table. The junior network administrator was not very successful. Now it is up to you to find and fix the misconfigurations before the CIO returns.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for uploading the configuration are provided at the end of this document.

Device

Command

R1

copy flash:/enarsi/5.1.3.1-r1-config.txt run

R2

copy flash:/enarsi/5.1.3.1-r2-config.txt run

R3

copy flash:/enarsi/5.1.3.1-r3-config.txt run

D1

copy flash:/enarsi/5.1.3.1-d1-config.txt run

D2

copy flash:/enarsi/5.1.3.1-d2-config.txt run

  • Passwords on all devices are cisco12345. If a username is required, use admin.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 4 intentional errors:

1)Stub router D1 is configured as Receive-Only, so its summary for Lo0-Lo4 is not being advertised. Because that summary is not being advertised, R1’s summary for the future range of networks is not being advertised.

2)R2 is configured to advertise a summary route of ::/0, when it should be a summary route of 2001:db8:acad:2000::/63.

3)R3 Loopback0 is being advertised into EIGRP, but it should not be.

4)The prefix list used by the distribute list on D2 is incorrectly configured, resulting in the default route that D2 is redistributing not being advertised. If the student does not fix the prefix list correctly, the extranet routes will appear in internal routing tables, which is not desired.

The commands used to fix these errors should be:

R2(config)# interface g0/0/0

R2(config-if)# no ipv6 summary-address eigrp 513 ::/0

R2(config-if)# ipv6 summary-address eigrp 513 2001:db8:acad:2000::/63

R2(config-if)# exit

R2(config)# interface g0/0/1

R2(config-if)# no ipv6 summary-address eigrp 513 ::/0

R2(config-if)# ipv6 summary-address eigrp 513 2001:db8:acad:2000::/63

R2(config-if)# end

R3(config)# router eigrp LAB513

R3(config-router)# address-family ipv6 unicast autonomous-system 513

R3(config-router-af)# af-interface loopback 0

R3(config-router-af-interface)# shutdown

R3(config-router-af-interface)# exit

R3(config-router-af)# exit

R3(config-router)# exit

R3(config)# end

D1(config)# router eigrp LAB513

D1(config-router)# address-family ipv6 unicast autonomous-system 513

D1(config-router-af)# no eigrp stub receive-only

D1(config-router-af)# eigrp stub

D1(config-router-af)# exit

D1(config-router)# exit

D1(config)# end

D2(config)# no ipv6 prefix-list NO-EXTRA

D2(config)# ipv6 prefix-list NO-EXTRA seq 5 permit ::/0

D2(config)# end

Router Interface Summary Table

Router Model

Ethernet Interface #1

Ethernet Interface #2

Serial Interface #1

Serial Interface #2

1800

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

1900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2801

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

2811

Fast Ethernet 0/0 (F0/0)

Fast Ethernet 0/1 (F0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

2900

Gigabit Ethernet 0/0 (G0/0)

Gigabit Ethernet 0/1 (G0/1)

Serial 0/0/0 (S0/0/0)

Serial 0/0/1 (S0/0/1)

4221

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

4300

Gigabit Ethernet 0/0/0 (G0/0/0)

Gigabit Ethernet 0/0/1 (G0/0/1)

Serial 0/1/0 (S0/1/0)

Serial 0/1/1 (S0/1/1)

Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

End of document

Uploading Configuration Files

Use the commands below to create the configuration files on the lab devices for each trouble ticket in this lab. The TCL script commands help create and copy the configurations. However, the configuration commands could also be copied and pasted directly into global config mode on each device. Simply remove the TCL script commands, enter the enable and configure t commands on the device, and copy and paste the configuration commands.

Important: The device requires a folder in flash named enarsi. Use the dir command to verify. If the folder is missing, then create it using the mkdir flash:/enarsi privileged exec command. For all switches, make sure the vlan.dat file is set to the default. Use the delete vlan.dat privileged EXEC command, if necessary.

Reset scripts

These TCL scripts will completely clear and reload the device in preparation for the next ticket. Copy and paste the appropriate script to the appropriate device.

Router Reset Script

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

puts “Reloading the router”

typeahead “\n”

reload

}

tclquit

D1/D2 (Cisco 3650) Reset Script – The default 3650 SDM template supports IPv6 by default, so it is not set by this script.

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

puts “Reloading the switch”

typeahead “\n”

reload

}

tclquit

A1 (Cisco 2960 Script) – The default 2960 SDM template does not support IPv6, so this script includes that setting.

tclsh

puts [ open “flash:reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

delete /force multiple-fs

ios_config “sdm prefer lanbase-routing”

typeahead “\n”

puts “Reloading the switch in 1 minute, type reload cancel to halt”

typeahead “\n”

reload

}

tclquit

R1 Configuration File Scripts

! R1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/5.1.3.1-r1-config.txt” w+ ] {

hostname R1

ipv6 unicast-routing

no ip domain lookup

enable secret cisco12345

username admin algorithm-type scrypt secret cisco12345

interface g0/0/0

ipv6 address fe80::1:1 link-local

ipv6 address 2001:db8:12::1/64

no shutdown

exit

interface g0/0/1

ipv6 address fe80::1:2 link-local

ipv6 address 2001:db8:1d1::1/64

no shutdown

exit

interface s0/1/0

ipv6 address fe80::1:3 link-local

ipv6 address 2001:db8:13::1/64

no shutdown

exit

router eigrp LAB513

address-family ipv6 unicast autonomous-system 513

eigrp router-id 1.1.1.1

af-interface g0/0/0

summary-address 2001:db8:acad:1000::/60

exit

af-interface s0/1/0

summary-address 2001:db8:acad:1000::/60

exit

exit

line con 0

logging synchronous

exec-timeout 0 0

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

R2 Configuration File Scripts

! R2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/5.1.3.1-r2-config.txt” w+ ] {

hostname R2

ipv6 unicast-routing

no ip domain lookup

enable secret cisco12345

username admin algorithm-type scrypt secret cisco12345

interface g0/0/0

ipv6 address fe80::2:1 link-local

ipv6 address 2001:db8:12::2/64

no shutdown

exit

interface g0/0/1

ipv6 address fe80::2:2 link-local

ipv6 address 2001:db8:23::2/64

no shutdown

exit

interface loopback 0

ipv6 address fe80::2:3 link-local

ipv6 address 2001:db8:acad:2000::1/64

no shutdown

exit

interface loopback 1

ipv6 address fe80::2:4 link-local

ipv6 address 2001:db8:acad:2001::1/64

no shutdown

exit

ipv6 router eigrp 513

eigrp router-id 2.2.2.2

exit

interface g0/0/0

ipv6 eigrp 513

ipv6 summary-address eigrp 513 ::/0

exit

interface g0/0/1

ipv6 eigrp 513

ipv6 summary-address eigrp 513 ::/0

exit

interface loopback 0

ipv6 eigrp 513

exit

line con 0

logging synchronous

exec-timeout 0 0

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

R3 Configuration File Scripts

!R3 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/5.1.3.1-r3-config.txt” w+ ] {

hostname R3

ipv6 unicast-routing

no ip domain lookup

enable secret cisco12345

username admin algorithm-type scrypt secret cisco12345

interface g0/0/0

ipv6 address fe80::3:1 link-local

ipv6 address 2001:db8:23::3/64

no shutdown

exit

interface g0/0/1

ipv6 address fe80::3:2 link-local

ipv6 address 2001:db8:3d2::1/64

no shutdown

exit

interface s0/1/0

ipv6 address fe80::3:3 link-local

ipv6 address 2001:db8:13::3/64

no shutdown

exit

interface loopback 0

ipv6 address fe80::3:4 link-local

ipv6 address 2001:db8:acad:3000::1/64

no shutdown

exit

router eigrp LAB513

address-family ipv6 unicast autonomous-system 513

eigrp router-id 3.3.3.3

exit

exit

line con 0

logging synchronous

exec-timeout 0 0

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

D1 Configuration File Scripts

! D1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/5.1.3.1-d1-config.txt” w+ ] {

hostname D1

ipv6 unicast-routing

no ip domain lookup

enable secret cisco12345

username admin algorithm-type scrypt secret cisco12345

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

no switchport

ipv6 address fe80::d1:1 link-local

ipv6 address 2001:db8:1d1::2/64

no shutdown

exit

interface loopback 0

ipv6 address fe80::d1:2 link-local

ipv6 address 2001:db8:acad:1000::1/64

no shutdown

exit

interface loopback 1

ipv6 address fe80::d1:3 link-local

ipv6 address 2001:db8:acad:1001::1/64

no shutdown

exit

interface loopback 2

ipv6 address fe80::d1:4 link-local

ipv6 address 2001:db8:acad:1002::1/64

no shutdown

exit

interface loopback 3

ipv6 address fe80::d1:5 link-local

ipv6 address 2001:db8:acad:1003::1/64

no shutdown

exit

router eigrp LAB513

address-family ipv6 unicast autonomous-system 513

eigrp router-id 131.131.131.131

eigrp stub receive-only

af-interface g1/0/11

summary-address 2001:db8:acad:1000::/62

exit

exit

line con 0

logging synchronous

exec-timeout 0 0

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

D2 Configuration File Scripts

! D2– Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/5.1.3.1-d2-config.txt” w+ ] {

hostname D2

ipv6 unicast-routing

no ip domain lookup

enable secret cisco12345

username admin algorithm-type scrypt secret cisco12345

interface range g1/0/1 – 24

switchport mode access

shutdown

exit

interface g1/0/11

no switchport

ipv6 address fe80::d2:1 link-local

ipv6 address 2001:db8:3d2::2/64

no shutdown

exit

interface loopback 0

description SIMULATED INTERNET

ipv6 address fe80::d2:2 link-local

ipv6 address 2001:db8:acad:4000::1/64

no shutdown

exit

interface loopback 1

description SIMULATED EXTRANET

ipv6 address fe80::d2:3 link-local

ipv6 address 2001:db8:acad:4001::1/64

no shutdown

exit

ipv6 prefix-list NO-EXTRA seq 5 deny 2001:db8:acad:4000::/63

ipv6 route ::/0 loopback 0

ipv6 route 3ff3:db8:acad::/48 loopback 1

router eigrp LAB513

address-family ipv6 unicast autonomous-system 513

eigrp router-id 132.132.132.132

topology base

redistribute static

distribute-list prefix NO-EXTRA out g1/0/11

exit

line con 0

logging synchronous

exec-timeout 0 0

exit

line vty 0 4

login local

transport input telnet

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

end

}

tclquit

A1 Configuration File Scripts – Not Used In This Lab

Leave a comment