10.1.2 Lab – Troubleshoot OSPFv3 Answers

10.1.2 Lab – Troubleshoot OSPFv3 Answers

Lab – Troubleshoot OSPFv3 (Answers Version)

Answers Note: Red font color or gray highlights indicate text that appears in the instructor copy only.

Topology

This topology has 3 routers, 2 switches and a PC. R2 G0/0/0 is connected to R1 G0/0/0. R1 G0/0/1 is connected D1 G1/0/11. D1 G1/0/1 is connected to D2 G1/0/1. D1 G1/0/2 is connected to D2 G1/0/2. D1 G1/0/3 is connected to D2 G1/0/3. D1 G1/0/4 is connected to D2 G1/0/4. D2 G1/0/11 is connected R3 G0/0/1. PC1 is connected to D1 G1/0/24.

Addressing Table

Device

Interface

IPv6 Address

Link-Local

R1

G0/0/0

2001:db8:acad:a201::1/64

fe80::a201:1

R1

G0/0/1

2001:db8:acad:a001::1/64

fe80::a001:1

R1

Lo1

2001:db8:feed:1::1/64

fe80::1:1

R2

G0/0/0

2001:db8:acad:a201::2/64

fe80::a201:2

R2

Lo1

2001:db8:acad:a202::1/64

fe80::a202:1

R3

G0/0/1

2001:db8:acad:a003::1/64

fe80::a003:1

R3

Lo1

2001:db8:acad:a301::1/64

fe80::a301:1

D1

G1/0/1 (Po1)

2001:db8:acad:a002::1/64

fe80::a002:1

D1

G1/0/2 (Po1)

2001:db8:acad:a002::1/64

fe80::a002:1

D1

G1/0/3 (Po2)

2001:db8:acad:a101::1/64

fe80::a101:1

D1

G1/0/4 (Po2)

2001:db8:acad:a101::1/64

fe80::a101:1

D1

G1/0/5

2001:db8:acad:a103::1/64

fe80::a103:1

D1

G1/0/11

2001:db8:acad:a001::2/64

fe80::a001:2

D1

G1/0/23

2001:db8:acad:a102::1/64

fe80::a102:1

D2

G1/0/1 (Po1)

2001:db8:acad:a002::2/64

fe80::a002:2

D2

G1/0/2 (Po1)

2001:db8:acad:a002::2/64

fe80::a002:2

D2

G1/0/3 (Po2)

2001:db8:acad:a101::2/64

fe80::a101:2

D2

G1/0/4 (Po2)

2001:db8:acad:a101::2/64

fe80::a101:2

D2

G1/0/11

2001:db8:acad:a003::2/64

fe80::a003:2

D2

Lo0

2001:db8:acad:a104::1/64

fe80::a104:1

PC1

N/A

SLAAC

SLAAC

Note: To make it easier to recognize IPv6 prefixes, familiarize yourself with the IPv6 GUA and LLA address formats.

  • GUA: The GUA has a 16-bit subnet-ID, a<area-id>xx (“a” for area). For example, subnet-ID a201 is area 2, network 01.
  • LLA: Following best practice the LLA address is unique on each interface. The LLA interface-ID uses the GUA subnet-ID:interface-ID for the last 64 bits. For example, fe80::a201:1 has an LLA interface-ID a201 (the subnet-ID of the GUA) and :1 (the Interface ID of the GUA).

Objectives

Troubleshoot network issues related to the configuration and operation of OSPFv3.

Background / Scenario

Although the topology has a limited number of routers, you should use the appropriate troubleshooting commands to help find and solve the problems in the three trouble tickets as if this were a much more complex topology with many more routers and networks.

You will be loading configurations with intentional errors onto the network. Your tasks are to FIND the error(s), document your findings and the command(s) or method(s) used to fix them, FIX the issue(s) presented here and then test the network to ensure both of the following conditions are met:

1)the complaint received in the ticket is resolved

2)full reachability is restored

Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4 (universalk9 image). The switches used in the labs are Cisco Catalyst 3650 with Cisco IOS XE Release 16.9.4 (universalk9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and the output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of the lab for the correct interface identifiers.

Note: Make sure that the devices have been erased and have no startup configurations. If you are unsure, contact your instructor.

Answers Note: Refer to the Answers Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 2 Switches (Cisco 3560 with Cisco IOS XE Release 16.9.4 universal image or comparable)
  • 1 PC (Choice of operating system with terminal emulation program installed)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Instructions

Part 1:Trouble Ticket 10.1.2.1

Scenario:

Your University network has migrated to IPv6-only internally and is using multiarea OSPFv3 address families. Recently your team configured all the necessary devices for this migration, with different people responsible for configuring different parts of the network.

During testing and validation, the network team noticed that routers are not showing the 2001:db8:acad:a202::/64 prefix in their routing tables.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for uploading the configuration are provided at the end of this document.

Device

Command

R1

copy flash:/enarsi/10.1.2.1-r1-config.txt run

R2

copy flash:/enarsi/10.1.2.1-r2-config.txt run

R3

copy flash:/enarsi/10.1.2.1-r3-config.txt run

D1

copy flash:/enarsi/10.1.2.1-d1-config.txt run

D2

copy flash:/enarsi/10.1.2.1-d2-config.txt run

  • All routers should have the 2001:db8:acad:a202::/64 network in their routing tables.
  • All devices should be able to ping 2001:db8:acad:a202::2/64.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains an intentional error:

  • R2 is configured for traditional OSPFv3 and not OSPFv3 AF. These two routing processes do NOT share routing information.

The commands used to fix these errors should be:

R2(config)# no ipv6 router ospf 1

R2(config)# router ospfv3 1

R2(config-router)# address-family ipv6 unicast

R2(config-router-af)# router-id 2.2.2.2

R2(config-router-af)# exit

R2(config-router)# inter g 0/0/0

R2(config-if)# no ipv6 ospf 1 area 2

R2(config-if)# ospfv3 1 ipv6 area 2

R2(config-if)# exit

R2(config)# inter lo 0

R2(config-if)# no ipv6 ospf 1 area 2

R2(config-if)# ospfv3 1 ipv6 area 2

R2(config-if)# exit

Part 2:Trouble Ticket 10.1.2.2

Scenario:

After a regularly scheduled downtime for maintenance and IOS upgrades, users started reporting to the helpdesk that there is no access to the IPv6 prefix in area 3. Although there are backups for all device configurations it is suspected that there some of the backups might not have been correct.

You have been tasked to find and resolve the issue with reaching the IPv6 prefix in area 3.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/10.1.2.2-r1-config.txt run

R2

copy flash:/enarsi/10.1.2.2-r2-config.txt run

R3

copy flash:/enarsi/10.1.2.2-r3-config.txt run

D1

copy flash:/enarsi/10.1.2.2-d1-config.txt run

D2

copy flash:/enarsi/10.1.2.2-d2-config.txt run

  • All routers should have the 2001:db8:acad:a301::/64 network in their routing tables.
  • All devices should be able to ping 2001:db8:acad:a301::1/64.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Then save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 1 intentional error. Router R3 was not configured with an OSPFv3 router ID. Because R3 does not have any interfaces with IPv4 addresses, the OSPF process was unable to create a 32-bit router ID.

The commands used to fix these errors should be:

R3(config-router)# router ospfv3 1

R3(config-router)# address-family ipv6 unicast

R3(config-router-af)# router-id 3.3.3.3

Part 3:Trouble Ticket 10.1.2.3

Scenario:

Network technicians recently installed a new router, R2 to area 2. However, during the verification phase the technicians are reporting that the other routers are not including the 2001:db8:acad:a202::/64 prefix in their routing tables. They call you for assistance.

Use the commands listed below to load the configuration files for this trouble ticket:

Answers Note: Commands for creating these files are at the end of this document.

Device

Command

R1

copy flash:/enarsi/10.1.2.3-r1-config.txt run

R2

copy flash:/enarsi/10.1.2.3-r2-config.txt run

R3

copy flash:/enarsi/10.1.2.3-r3-config.txt run

D1

copy flash:/enarsi/10.1.2.3-d1-config.txt run

D2

copy flash:/enarsi/10.1.2.3-d2-config.txt run

Note: To simulate the link being cut, shutdown the G0/0/1 interface on R3:

  • PC1 should be able to ping 2001:db8:acad:a301::1.
  • Network 2001:db8:acad:a301::/64 must be in its own area.
  • When you have fixed the ticket, change the MOTD on EACH DEVICE using the following command:

banner motd # This is $(hostname) FIXED from ticket <ticket number> #

  • Save the configuration by issuing the wri command (on each device).
  • Inform your instructor that you are ready for the next ticket.
  • After the instructor approves your solution for this ticket, issue the reset.now privileged EXEC command. This script will clear your configurations and reload the devices.

Answers Notes:

This trouble ticket contains 1 intentional error. On R2 the hello-interval is 5 but the dead-interval was not configured. By default, OSPF uses 4 times the hello-interval, which results in 20 seconds for R2. R1 is the adjacent router and is configured with a hello-interval of 5 and a dead-interval of 15.

The commands used to fix these errors should be:

R2(config)# inter g 0/0/0

R2(config-if)# ospfv3 dead-interval 15

Uploading Configuration Files

Use the commands below to create the configuration files for each trouble ticket in this lab on the lab devices. The TCL script commands help create and copy the configurations. However, the configuration commands could also be copied and pasted directly into global config mode on each device. Simply remove the TCL script commands, enter the enable and configure t commands on the device, and copy and paste the configuration commands.

Important: The device requires a folder in flash named enarsi. Use the dir command to verify. If the folder is missing, then create it using the mkdir flash:/enarsi privileged EXEC command. For all switches, make sure the vlan.dat file is set to the default. Use the delete vlan.dat privileged EXEC command, if necessary.

Reset scripts

These TCL scripts will completely clear and reload the device in preparation for the next ticket. Copy and paste the appropriate script to the appropriate device.

Router Reset Script

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

puts “Reloading the router”

typeahead “\n”

reload

}

tclquit

D1/D2 (Cisco 3650) Reset Script – The default 3650 SDM template supports IPv6 by default, so it is not set by this script.

tclsh

puts [ open “flash:/enarsi/reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

puts “Reloading the switch”

typeahead “\n”

reload

}

tclquit

A1 (Cisco 2960 Script) – The default 2960 SDM template does not support IPv6, so this script includes that setting.

tclsh

puts [ open “flash:reset.tcl” w+ ] {

typeahead “\n”

copy running-config startup-config

typeahead “\n”

erase startup-config

delete /force vlan.dat

delete /force multiple-fs

ios_configsdm prefer lanbase-routing”

typeahead “\n”

puts “Reloading the switch in 1 minute, type reload cancel to halt”

typeahead “\n”

reload

}

tclquit

R1 Configuration File Scripts

!R1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/10.1.2.1-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 10.1.2.1 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ipv6 add 2001:db8:acad:a201::1/64

ipv6 add fe80::a201:1 link-local

ospfv3 1 ipv6 area 2

no shut

inter g 0/0/1

ipv6 add 2001:db8:acad:a001::1/64

ipv6 add fe80::a001:1 link-local

ospfv3 1 ipv6 area 0

no shut

int lo0

ipv6 add 2001:db8:feed:1::1/64

ipv6 add fe80::1:1 link-local

exit

router ospfv3 1

address-family ipv6 unicast

router-id 1.1.1.1

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!R1 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/10.1.2.2-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 10.1.2.2 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ipv6 add 2001:db8:acad:a201::1/64

ipv6 add fe80::a201:1 link-local

ospfv3 1 ipv6 area 2

no shut

inter g 0/0/1

ipv6 add 2001:db8:acad:a001::1/64

ipv6 add fe80::a001:1 link-local

ospfv3 1 ipv6 area 0

no shut

int lo0

ipv6 add 2001:db8:feed:1::1/64

ipv6 add fe80::1:1 link-local

exit

router ospfv3 1

address-family ipv6 unicast

router-id 1.1.1.1

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!R1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/10.1.2.3-r1-config.txt” w+ ] {

hostname R1

banner motd # This is R1, Trouble Ticket 10.1.2.3 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ipv6 add 2001:db8:acad:a201::1/64

ipv6 add fe80::a201:1 link-local

ospfv3 1 ipv6 area 2

ospfv3 hello-interval 5

ospfv3 dead-interval 15

no shut

inter g 0/0/1

ipv6 add 2001:db8:acad:a001::1/64

ipv6 add fe80::a001:1 link-local

ospfv3 1 ipv6 area 0

no shut

int lo0

ipv6 add 2001:db8:feed:1::1/64

ipv6 add fe80::1:1 link-local

exit

router ospfv3 1

address-family ipv6 unicast

router-id 1.1.1.1

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

R2 Configuration File Scripts

!R2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/10.1.2.1-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 10.1.2.1 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ipv6 add 2001:db8:acad:a201::2/64

ipv6 add fe80::a201:2 link-local

ipv6 ospf 1 area 2

no shut

inter lo 0

ipv6 add 2001:db8:acad:a202::1/64

ipv6 add fe80::a202:1 link-local

ipv6 ospf 1 area 2

ipv6 ospf network point-to-point

no shut

exit

ipv6 router ospf 1

router-id 2.2.2.2

area 2 stub

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!R2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/10.1.2.2-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 10.1.2.2 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ipv6 add 2001:db8:acad:a201::2/64

ipv6 add fe80::a201:2 link-local

ospfv3 1 ipv6 area 2

no shut

inter lo 0

ipv6 add 2001:db8:acad:a202::1/64

ipv6 add fe80::a202:1 link-local

ospfv3 1 ipv6 area 2

ipv6 ospf network point-to-point

no shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 2.2.2.2

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!R2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/10.1.2.3-r2-config.txt” w+ ] {

hostname R2

banner motd # This is R2, Trouble Ticket 10.1.2.3 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/0

ipv6 add 2001:db8:acad:a201::2/64

ipv6 add fe80::a201:2 link-local

ospfv3 1 ipv6 area 2

ospfv3 hello-interval 5

no shut

inter lo 0

ipv6 add 2001:db8:acad:a202::1/64

ipv6 add fe80::a202:1 link-local

ospfv3 1 ipv6 area 2

ipv6 ospf network point-to-point

no shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 2.2.2.2

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

R3 Configuration File Scripts

!R3 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/10.1.2.1-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 10.1.2.1 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/1

ipv6 add 2001:db8:acad:a003::1/64

ipv6 add fe80::a003:1 link-local

ospfv3 1 ipv6 area 0

no shut

inter lo 0

ipv6 add 2001:db8:acad:a301::1/64

ipv6 add fe80::a301:1 link-local

ospfv3 1 ipv6 area 3

ipv6 ospf network point-to-point

no shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 3.3.3.3

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!R3 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/10.1.2.2-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 10.1.2.2 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/1

ipv6 add 2001:db8:acad:a003::1/64

ipv6 add fe80::a003:1 link-local

ospfv3 1 ipv6 area 0

no shut

inter lo 0

ipv6 add 2001:db8:acad:a301::1/64

ipv6 add fe80::a301:1 link-local

ospfv3 1 ipv6 area 3

ipv6 ospf network point-to-point

no shut

exit

router ospfv3 1

address-family ipv6 unicast

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!R3 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/10.1.2.3-r3-config.txt” w+ ] {

hostname R3

banner motd # This is R3, Trouble Ticket 10.1.2.3 #

no ip domain lookup

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 0/0/1

ipv6 add 2001:db8:acad:a003::1/64

ipv6 add fe80::a003:1 link-local

ospfv3 1 ipv6 area 0

no shut

inter lo 0

ipv6 add 2001:db8:acad:a301::1/64

ipv6 add fe80::a301:1 link-local

ospfv3 1 ipv6 area 3

ipv6 ospf network point-to-point

no shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 3.3.3.3

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

D1 Configuration File Scripts

!D1 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/10.1.2.1-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 10.1.2.1 #

no ip domain lookup

ip routing

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ipv6 add 2001:db8:acad:a001::2/64

ipv6 add fe80::a001:2 link-local

ospfv3 1 ipv6 area 0

no shut

exit

inter g 1/0/23

no switchport

ipv6 add 2001:db8:acad:a102::1/64

ipv6 add fe80::a102:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

inter g 1/0/24

no switchport

ipv6 add 2001:db8:acad:a103::1/64

ipv6 add fe80::a103:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

interface g 1/0/1

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/2

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/3

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

interface g 1/0/4

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

inter port-channel 1

ipv6 add 2001:db8:acad:a002::1/64

ipv6 add fe80::a002:1 link-local

ospfv3 1 ipv6 area 0

no shut

exit

inter port-channel 2

ipv6 add 2001:db8:acad:a101::1/64

ipv6 add fe80::a101:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

inter range g1/0/5-10, g1/0/12-22

shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 4.4.4.4

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!D1 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/10.1.2.2-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 10.1.2.2 #

no ip domain lookup

ip routing

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ipv6 add 2001:db8:acad:a001::2/64

ipv6 add fe80::a001:2 link-local

ospfv3 1 ipv6 area 0

no shut

exit

inter g 1/0/23

no switchport

ipv6 add 2001:db8:acad:a102::1/64

ipv6 add fe80::a102:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

inter g 1/0/24

no switchport

ipv6 add 2001:db8:acad:a103::1/64

ipv6 add fe80::a103:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

interface g 1/0/1

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/2

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/3

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

interface g 1/0/4

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

inter port-channel 1

ipv6 add 2001:db8:acad:a002::1/64

ipv6 add fe80::a002:1 link-local

ospfv3 1 ipv6 area 0

no shut

exit

inter port-channel 2

ipv6 add 2001:db8:acad:a101::1/64

ipv6 add fe80::a101:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

inter range g1/0/5-10, g1/0/12-22

shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 4.4.4.4

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!D1 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/10.1.2.3-d1-config.txt” w+ ] {

hostname D1

banner motd # This is D1, Trouble Ticket 10.1.2.3 #

no ip domain lookup

ip routing

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ipv6 add 2001:db8:acad:a001::2/64

ipv6 add fe80::a001:2 link-local

ospfv3 1 ipv6 area 0

no shut

exit

inter g 1/0/23

no switchport

ipv6 add 2001:db8:acad:a102::1/64

ipv6 add fe80::a102:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

inter g 1/0/24

no switchport

ipv6 add 2001:db8:acad:a103::1/64

ipv6 add fe80::a103:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

interface g 1/0/1

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/2

description Channel to D2

no switchport

channel-group 1 mode on

no shutdown

exit

interface g 1/0/3

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

interface g 1/0/4

description Channel to D2

no switchport

channel-group 2 mode on

no shutdown

exit

inter port-channel 1

ipv6 add 2001:db8:acad:a002::1/64

ipv6 add fe80::a002:1 link-local

ospfv3 1 ipv6 area 0

no shut

exit

inter port-channel 2

ipv6 add 2001:db8:acad:a101::1/64

ipv6 add fe80::a101:1 link-local

ospfv3 1 ipv6 area 1

no shut

exit

inter range g1/0/5-10, g1/0/12-22

shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 4.4.4.4

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

D2 Configuration File Scripts

!D2 – Trouble Ticket # 1

tclsh

puts [ open “flash:/enarsi/10.1.2.1-d2-config.txt” w+ ] {

hostname D2

banner motd # This is D2, Trouble Ticket 10.1.2.1 #

no ip domain lookup

ip routing

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ipv6 add 2001:db8:acad:a003::2/64

ipv6 add fe80::a003:2 link-local

ospfv3 1 ipv6 area 0

no shut

interface g 1/0/1

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/2

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/3

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

interface g 1/0/4

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

inter lo 0

ipv6 add 2001:db8:acad:a104::1/64

ipv6 add fe80::a104:1 link-local

ospfv3 1 ipv6 area 1

ipv6 ospf network point-to-point

no shut

inter port-channel 1

ipv6 add 2001:db8:acad:a002::2/64

ipv6 add fe80::a002:2 link-local

ospfv3 1 ipv6 area 0

no shut

inter port-channel 2

ipv6 add 2001:db8:acad:a101::2/64

ipv6 add fe80::a101:2 link-local

ospfv3 1 ipv6 area 1

no shut

inter range g1/0/5-10, g1/0/12-24

shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 5.5.5.5

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!D2 – Trouble Ticket # 2

tclsh

puts [ open “flash:/enarsi/10.1.2.2-d2-config.txt” w+ ] {

hostname D2

banner motd # This is D2, Trouble Ticket 10.1.2.2 #

no ip domain lookup

ip routing

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ipv6 add 2001:db8:acad:a003::2/64

ipv6 add fe80::a003:2 link-local

ospfv3 1 ipv6 area 0

no shut

interface g 1/0/1

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/2

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/3

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

interface g 1/0/4

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

inter lo 0

ipv6 add 2001:db8:acad:a104::1/64

ipv6 add fe80::a104:1 link-local

ospfv3 1 ipv6 area 1

ipv6 ospf network point-to-point

no shut

inter port-channel 1

ipv6 add 2001:db8:acad:a002::2/64

ipv6 add fe80::a002:2 link-local

ospfv3 1 ipv6 area 0

no shut

inter port-channel 2

ipv6 add 2001:db8:acad:a101::2/64

ipv6 add fe80::a101:2 link-local

ospfv3 1 ipv6 area 1

no shut

inter range g1/0/5-10, g1/0/12-24

shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 5.5.5.5

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

!D2 – Trouble Ticket # 3

tclsh

puts [ open “flash:/enarsi/10.1.2.3-d2-config.txt” w+ ] {

hostname D2

banner motd # This is D2, Trouble Ticket 10.1.2.3 #

no ip domain lookup

ip routing

ipv6 unicast-routing

line con 0

logg sync

exec-time 0 0

exit

inter g 1/0/11

no switchport

ipv6 add 2001:db8:acad:a003::2/64

ipv6 add fe80::a003:2 link-local

ospfv3 1 ipv6 area 0

no shut

interface g 1/0/1

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/2

description Channel to D1

no switchport

channel-group 1 mode on

no shutdown

interface g 1/0/3

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

interface g 1/0/4

description Channel to D1

no switchport

channel-group 2 mode on

no shutdown

inter lo 0

ipv6 add 2001:db8:acad:a104::1/64

ipv6 add fe80::a104:1 link-local

ospfv3 1 ipv6 area 1

ipv6 ospf network point-to-point

no shut

inter port-channel 1

ipv6 add 2001:db8:acad:a002::2/64

ipv6 add fe80::a002:2 link-local

ospfv3 1 ipv6 area 0

no shut

inter port-channel 2

ipv6 add 2001:db8:acad:a101::2/64

ipv6 add fe80::a101:2 link-local

ospfv3 1 ipv6 area 1

no shut

inter range g1/0/5-10, g1/0/12-24

shut

exit

router ospfv3 1

address-family ipv6 unicast

router-id 5.5.5.5

exit

alias exec reset.now tclsh flash:/enarsi/reset.tcl

}

tclquit

A1 Configuration File Scripts – Not Used In This Lab

Leave a comment